Ubuntu 9.10 running a Windows XP guest in virtualbox.

At work they recently switched to ip telephony, our supplier haven’t got any Linux client for their softphone so I had to install windows just to have a working phone !

So I end up running Virtualbox-ose and setting up a windows guest.
After installing windows xp (which takes AGES) I installed the softphone application, but my michrophone didn’t work in the guest environment !
The mic did work OK in Ubuntu, so I ended up debugging ( a lot).
I came over several people having the same problem + launchpad had a bug reported on the problem.
I uninstalled pulseaudio and the mic started working OK in the guest.
I had to do a
apt-get purge pulseaudio gstreamer0.10-pulseaudio + the rest of my packages related to pulse (found via dpkg -l | grep pulse),
except i still got libpulse-browse0 libpulse-mainloop-glib0 and libpulse0
Apt tells you it’s removing ubuntu-desktop as well, which probably is because ubuntu-desktop got pulse as a dependency or something. I find that apt-get doesn’t remove as much as aptitude wants to, so I used apt-get for this one.

I also installed gnome-alsamixer alsa alsa-firmware-loaders alsa-tools alsa-tools-gui
and reboot

note: volume control (in tray) and ‘system -> preferences -> sound’ in gnome is now broken, but I kan control sound via gnome-alsamixer

UPDATE UPDATE: see this post regarding “I no longer need windows for my companys ip telephone solution”

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>